1969 Fiat 124 Sport

This section is a bulletin board for your Fiat club
Jvisconti
Posts: 12
Joined: Sun May 18, 2014 12:35 pm
Your car is a: 1969 Fiat 124 Sport
Location: Coralville IA

1969 Fiat 124 Sport

Postby Jvisconti » Tue May 20, 2014 5:43 pm

I have a 1969 Fiat 124 sport. Installed new battery no problem, shut it off and would not start check wires and no spark ( this happened out side auto parts store) pulled off distributor and checked points, look fine,rotor looks gook and cap is good so bought a coil still no spark. so ordered points and condenser. towed home and tried an older condenser no luck. Parts came in a couple of days installed them still nothing, pulled off distributor again and found new points wire had 2 small bare spots, so regapped old points, and now have some sputtering and back fire, I'm sure the timing is out of wack, can't seem to get the cam mark in #1 position can always get it in a 11 o'clock, my question is what # plug is that, or any suggestions on how to get cam in #1 position, I thought I had kept the distributor in a good position but my guess now. Timming

User avatar
sonosml
Posts: 64
Joined: Thu Feb 12, 2009 9:20 pm
Your car is a: 74 and 75 124 spider
Location: Anamosa Iowa

Re: 1969 Fiat 124 Sport

Postby sonosml » Wed Apr 22, 2015 12:20 am

Hi. Are you still in coral vile and have the '69.

We should meet. I'm 40 min north of you in anamosa.

IA-mike


Return to “CLUB FORUMS”

Who is online

Users browsing this forum: No registered users and 1 guest